Follow

IsatPhone PRO Firmware

IsatPhone PRO current firmware: 5.17.2

IMPORTANT! If your IsatPhone PRO satellite phone's firmware version is lower than 5.3.0, your phone will NOT operate properly. You must update to the current firmware in order to use your Inmarsat phone and service.

For users of 5.3.0 or higher this is a recommended upgrade, meaning that the features introduced by the firmware are important but not critical for the service, including the network and the IsatPhone Pro handset. The 5.17.2 update is mandatory only for users covered by the MEAS (I4-F2) satellite region.

To check your phone's firmware version, go to Menu > Settings > About > Firmware version.

You can download the firmware update tool and instructions at Inmarsat website.

WARNING, please read!

  • Read the entire document with instructions before attempting an upgrade!
  • All firmware upgrades, tools and instructions have been designed, produced and provided by Inmarsat. By performing a firmware upgrade, you will assume all and any risk. Your equipment may be damaged or bricked and repair may be required. SATTRANS shall not be responsible for any damage to your equipment and/or costs of repair/replacement as a result of firmware upgrades.
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk