Follow

EMEA BGAN users should upgrade LaunchPad software by March 31, 2015

All Inmarsat BGAN users with land terminals operating in the EMEA region and using LaunchPad should upgrade to the latest version of LaunchPad, which includes the Alphasat satellite coverage map.

Previous versions of LaunchPad will be compatible with Alphasat but will display the I-4 F2 coverage for EMEA rather than the Alphasat coverage. (NOTE: No action is required for maritime terminals)

You can view all Inmarsat LaunchPad downloads at Inmarsat BGAN-LaunchPad Support. If you have questions, please contact us at +1 877 688-4635 or [email protected].

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk